Share:

Ya hemos sido testigos de diversas vulnerabilidades tales como la reciente que afectaba a WinRar, o las que afectan a hardware como la descubierta recientemente MDS con CPUIntel.

En este caso es el turno de VLC, el reproductor multimedia en sus versiones 3.0.6. y anteriores presenta una brecha de seguridad que ha sido descubierta por Pen Test Partners, y ha sido clasificada como crítica recibiendo una puntuación en el baremo CVSS v3 de 9.8 (donde 10 es el máximo). La brecha ha sido rastreada como CVE-2019-12874.

La función del reproductor “zlib_decompress_extra” que se ejecuta al analizar los datos de un archivo MKV con formato incorrecto puede activar la vulnerabilidad, permitiendo atacantes instalar o ejecutar malware con privilegios de usuario.

La vulnerabilidad se corrige con la actualización a la última versión (3.0.7), la cual también soluciona un problema observado con desbordamiento de buffer a través de la función ReadFrame en archivos específicos .avi.

Ambos problemas han sido solucionados según asegura VLC, y ya está disponible la actualización 3.0.7.1 para descargar desde su página web, para este popular reproductor.

Fuente: geeknetic.es

Please follow and like us:
Share: